Leute sind auf einmal weg

Es gibt 14 Antworten im Thema. Der letzte Beitrag () ist von Leabasan

    Leute sind auf einmal weg

    Ich poste das einfach mal in allen Foren, in denen sich Dazzler rumtreiben...

    Ich bin dabei, ein Gruppenbild zu rendern. Ich habe die Szene aufgesetzt mit 2x G2M, 2x G3F, 1x G (2F? - ich weiß nicht mehr, was ich als base genommen habe). Da hat auch noch alles ganz wunderbar funktioniert. Dann habe ich die Szene unter einem neuen Namen gespeichert und einen G3M hinzugefügt, den ich als EINZIGEN noch weiter bearbeitet habe - die andern hab ich nicht angefasst.
    Jetzt habe ich gerendert (alles 3DL mit passenden Shadern, darauf habe ich geachtet), und auf einmal sind die Leute weg! Eine G3F fehlt INKLUSIVE ihrer Rüstung, bei allen anderen fehlen die Haut-Texturen und hinterlassen nur Löcher - als ob ich alles auf Fantom gestellt hätte (was ich nicht habe).

    Irgendwer eine Idee, was da passiert sein könnte?




    Für Computer braucht man keine Experten, sondern Schamanen.

    Meine DeviantArt-Seite
    Da trauste Deinen Augen nicht! Genau das hatte ich auch schon öfter, dass die Hauttexturen weg waren. Eine ganze Figur ist allerdings bisher noch nicht verschwunden. Hast Du vielleicht eine andere Camera beim Rendern genutzt (ich hab immer mehrere in der Szene, daher meine Frage)

    Manchmal hilft es das Studio komplett zu schließen und wieder zu öffnen.
    ~ *Man sieht nur mit dem Herzen gut. Das Wesentliche ist für die Augen unsichtbar.*~
    Ui, da hat wohl einer beim Invis casten gefumbled *lol*

    Das Problem hatte ich so direkt noch nicht. Allerdings habe ich es relativ oft, das die Texturen einfach knatsch weiß werden. Ich bin zwar nicht 100%ig sicher, habe aber den RAM (bzw. Mangel desselben) im Verdacht. Bei so vielen G2s und G3s kann ich mir vorstellen, daß das auch dein Problem verursachen könnte...

    PS: Das Problem tritt bei mir nur bei G2 und G3 mit Originaltexturen auf. Bei Generation 4 Texturen mit HSS habe ich keine Probleme in der Art ;)
    "Alles, was man sich vorstellen kann, ist real"
    Pablo Picasso
    So etwas habe ich selber zwar nicht gehabt bisher. Aber DAZ geht auf jeden Fall verschwenderisch mit dem Speicher um.
    Gerade wenn man viel an den Materialien arbeitet da schleppt DAZ oft den alten Kram einfach mit.
    Ist n bissl wie bei Word früher :)
    Einfach mal unter einem anderen Namen neu speichern hilft. Das wird auch empfohlen z.b. beim Scene Optimizer. Nue speicher, DAZ schliessen und neu öffnen. Das hilft wunder manchmal. :)
    MFG Hubby72

    Mein Blog : subwaytotatooine.de/
    Meine Deviant Art Seite : hubby72.deviantart.com/
    Meine Deviant Art Gruppe : 3d-art-and-themes.deviantart.com/
    Blinker = an, aus, an ^^

    Och, manchmal war ich schon ganz froh, dass alte Texturen noch mitgeschleppt wurden und ich sie nicht wieder auf meinem Computer raussuchen musste... Aber ja, das ist für den RAM nicht so toll. Daz-Reboot hilft bei vielen Sachen. Manche frisst man dadurch aber auch erst fest, gerade wenn es um Merkwürdigkeiten des Layouts oder so geht.
    Für Computer braucht man keine Experten, sondern Schamanen.

    Meine DeviantArt-Seite
    @Lessa
    Ja, das ist gewissermaßen ein 'Speicher-Problem'.

    Bezieht sich allerdings weniger auf den System-RAM oder GraKa-Speicher, als eher darauf, dass D|S beim Transfer/Kompilieren so großer Geometrie- und Textur-Datenmengen zu/für 3DL schon gern mal Schluckauf bekommt. Dann werden die Oberflächen halt schwarz oder verschwinden mitunter sogar komplett. Ein Neustarten des Programms bzw. der Szene hilft da insofern, dass eben bspw. nur noch die Texturen geladen werden, die auch in der Szene vorhanden sind. Allerdings bleibt es bei 6(?) G2/G3-Chars ja trotzdem noch 'n ganz ordentlicher Texturbatzen. :)

    Du könntest gucken, dass du die Texturen etwas optimierst, insbesondere vielleicht in Sachen Auflösung oder auch schauen, dass nicht unnötig viele Texturen geladen werden (man denke nur daran, dass bei den Mat-Presets nicht eben selten nur für die Nasenlöcher schon eine eigene 4k-Textur verwenden wird ;) .. oder für die Lippen). Darüber hinaus mag vielleicht auch ein Umstellen auf die UberSurface helfen. Habe den Eindruck, dass die ein bisschen zuverlässiger und schneller rendert und auch weniger zu Problemchen neigt, als AoA's Subsurface. (Ist allerdings nur mein rein subjektiver Eindruck.) Ansonsten lässt sich da leider sehr wenig machen .. ist halt D|S' internes Speichermanagement :/ .. vielleicht davon abgesehen, mit der Standalone-Version von 3DeLight zu rendern. ;)

    Das von @Leabasan erwähnte Dingens in Bezug auf die komplett weißen Oberflächen ist wieder eine etwas andere Baustelle. Da hat die Renderengine lediglich bei der Pre-Kalkulation des SSS Schluckauf .. aber dies lässt sich i.d.R. ja einfach durch ein Neustarten des Rendervorgangs beheben.
    it's the artist, not the tool!
    Dann bin ich mal gespannt, wie DS auf noch zwei weitere Gestalten reagiert (der Magier und der Blutwüter fehlen noch) - außerdem muss ich noch einige Texturen auf eine Geoshell tun, weil der Schurke ein Sylph ist und die so Swirlies auf der Haut haben...

    Ich mag US auch lieber als AoA, weil es auch eine Translucency-Option bietet. Allerdings finde ich es schwierig, die SSS-Einstellungen, die ja bei den Charakteren über AoA bereits optimiert sind, in US wiederherzustellen. Besser gesagt, bisher war ich zu faul ^^
    Für Computer braucht man keine Experten, sondern Schamanen.

    Meine DeviantArt-Seite
    Also das mit dem Weiß kommt vor allem bei Genesis und Genesis2 vor. Da hilft ein Neustart.
    Falls die Haut gerippelt ist, hilft es manchmal, die ID zu ändern.
    In Iray kann man ja zumindest auf Optimize Memory stellen. In 3DL leider nicht.

    Ich hatte vor einigen Tagen so ein ähnliches Problem, als ich das Kaleidoskop verwenden wollte:
    daz3d.com/kaleidoscope
    Interessanterweise war dann aber dieser Typ hier plötzlich völlig verschwunden und nur noch seine Hose sichtbar, obwohl 3DL-geshadert:
    daz3d.com/robbus-goblin-hd-for-genesis-3-male
    Habe ihm dann einfach die Iray-Materialien verpasst und das in 3DL gerendert.
    Der Grund liegt wahrscheinlich darin, dass das Kaleidoskop eine spezielle (geheime) Shader-Einstellung benutzt um Figuren vom Spiegeln auszuschließen.

    Schön, dass andere auch solche Problme haben.

    Ich hatte auch schon mal beim Kamel das Problem, als ich >= 6 Exemplare in der Szene hatte, dass bei einigen der Schatten verschwand und bei anderen nicht ;)
    Computer sind hinterhältig und gemein

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „mbarnick“ ()

    mbarnick schrieb:

    Also das mit dem Weiß kommt vor allem bei Genesis und Genesis2 vor. Da hilft ein Neustart.
    Falls die Haut gerippelt ist, hilft es manchmal, die ID zu ändern.


    Beides hilft bei mir eher selten (mein RAM ist mit 4GB aber auch schon sehr knapp für Genesis+). Was immer funktioniert ist den guten alten Human Surface Shader zu benutzen :)
    "Alles, was man sich vorstellen kann, ist real"
    Pablo Picasso

    mbarnick schrieb:

    Human Surface Shader????
    Schon mal gehört, aber ich stehe jetzt auf der Leitung.
    Wo finde ich den? Ist der in der Nähe von den anderen 3DL- Shadern wie matte, pastic, ...?


    Der "Elite Human Surface Shader" ist ein spezieller 3DL Hautshader von Omnifreaker, den es früher mal als Freebie gab. Inzwischen ist er glaube ich ein Teil des "Uber Shader Pack", kann ich aber nicht mit Sicherheit sagen. Das besondere ist/war, daß der HSS Hauttexturen mit Subsurface, translucency usw versorgt und damit das alte "In 3DL sieht jede Haut wie Plastik aus" Problem aushebelt. Für alles was nach Generation 4 gekommen ist, braucht man den i.d.R. nicht. Aber wenn man ihn hat, lassen sich damit halt die "Haut wird weiß" und "Haut wie ein Zebra" Probleme lösen.
    Das schöne an dem Shader ist, daß er weitestgehend UV-Map unabhängig ist was menschliche Figuren betrifft und damit generationsunabhängig (hab ihn allerdings noch nicht an G8 getestet).
    "Alles, was man sich vorstellen kann, ist real"
    Pablo Picasso